1. INTRODUCTION

1.1 Foreword

1.1.1 How to use this manual

1.1.2 Conventions adopted in the manual

1.1.3 The work environment

1.2 The Genesis window

1.2.1 Structure of the Genesis window

1.2.2 The Title Bar

1.2.3 The Menu Bar

1.2.4 The Toolbar

1.2.5 Work Area

1.2.6 The Errors Bar

1.2.7 The Status Bar

1.2.8 How to activate or hide the Bars

1.2.9 Selection of the desired operation

1.2.10 The operating windows of Genesis

1.2.11 Genesis Menus

1.3 General commands

1.3.1 Close the current window

1.3.2 Exit Genesis

1.3.3 Character setting

1.3.4 Arranging windows

1.3.5 Arrange icons

1.3.6 Change the active work window

1.3.7 Guide of Genesis

2. SYSTEM COMPOSITION

2.1 Foreword

2.2 Architecture of a typical Genesis system

2.3 Organisation and logical configuration

2.4 The Devices

2.4.1 Physical devices

2.4.2 Logical devices

3. EXECUTION LIST

3.1 Preliminary

3.2 Creation of a List

3.2.1 Create a new list

3.2.2 List Properties

3.2.3 Composition of window “Execution List”

3.3 Filing a list

3.3.1 How to save a list

3.3.2 Create a new list while saving
4. SYNOPTIC TABLE

4.1 Use of Synoptic Table
  4.1.1 Displaying Synoptic Table
  4.1.2 Open a new Synoptic Table
  4.1.3 How to come back to previous Synoptic
  4.1.4 How to come back to Main Synoptic

4.2 How to operate on the Synoptic Table
  4.2.1 How to act on Devices
  4.2.2 Moving Axes in Manual

3.10 List Execution
  3.10.1 Control of execution
  3.10.2 Displays during execution

3.11 List Manager

3.12 Definition of working fields and working codes

3.13 Execution modes on working fields

3.4 Opening an existing list

3.5 Print a List
  3.5.1 Print a List
  3.5.2 Print preview
  3.5.3 Printer Setup

3.6 How to operate on a list
  3.6.1 Available keys
  3.6.2 Using mouse
  3.6.3 How to point to the selected box
  3.6.4 Selecting and unselecting a number of lines
  3.6.5 Selecting all lines
  3.6.6 Unselecting all lines

3.7 Insertions and modifications in a List
  3.7.1 Inserting new lines
  3.7.2 Editing content of current box
  3.7.3 Import from program archive
  3.7.4 List of lists
  3.7.5 Import from program archive
  3.7.6 Editing content of current box
  3.7.7 Inserting new lines
  3.7.8 Replace
  3.7.9 New search
  3.7.10 Find
  3.7.11 Delete
  3.7.12 Copying from memory
  3.7.13 Copy into memory
  3.7.14 Cut and save into memory
  3.7.15 Delete last operation

3.8 Editing a list
  3.8.1 Delete last operation
  3.8.2 Cut and save into memory
  3.8.3 Copy into memory
  3.8.4 Copying from memory
  3.8.5 Delete
  3.8.6 Find
  3.8.7 New search
  3.8.8 Replace

3.9 Other commands available
  3.9.1 Protect a List
  3.9.2 Repeat a List

3.10 List Execution
  3.10.1 Control of execution
  3.10.2 Displays during execution

3.11 List Manager

3.12 Definition of working fields and working codes

3.13 Execution modes on working fields

4. SYNOPTIC TABLE

4.1 Use of Synoptic Table
  4.1.1 Displaying Synoptic Table
  4.1.2 Open a new Synoptic Table
  4.1.3 How to come back to previous Synoptic
  4.1.4 How to come back to Main Synoptic

4.2 How to operate on the Synoptic Table
  4.2.1 How to act on Devices
  4.2.2 Moving Axes in Manual
5. DIAGNOSTIC .................................................................................................................................
5.1 Foreword ........................................................................................................................................
5.2 Diagnostic window ........................................................................................................................
  5.2.1 Opening Diagnostic window ......................................................................................................
  5.2.2 Opening subsidiary Diagnostic windows ....................................................................................
  5.2.3 Window Composition ..................................................................................................................
5.3 Device Representation ......................................................................................................................
5.4 Interacting with Devices ..................................................................................................................
1. INTRODUCTION

1.1 Foreword

The present Manual describes user operation of the Numerical Control GENESIS, helping the operator in his interaction with the machine.

The manual has been conceived in order to most efficiently guide the operator in understanding and using the system.

1.1.1 How to use this manual

For best results, we suggest that you first get a quick general view of the manual, going deeper into the different items as long as this will be required by the daily work. This first view will give a general idea of what is available for future needs.

The present Operational Manual is structured in the following chapters:

Chap. 1 illustrates the conventions adopted in the manual, the windows, the tools of Genesis.

Chap. 2 describes Genesis architecture for the present application.

Chap. 3 describes the formalities of creation and elaboration / execution of the program/piece to be worked.

Chap. 4 describes the functionality of Synoptic, to visualise the state of the devices and to effect diagnostic interventions or move axes in Manual.

Chap. 5 how to display Devices and operate on them with manual and diagnostic functions.

In order to avoid an excessive overhead of the present manual, the reader is invited to make reference to the manuals of Windows® Operating System, for a complete learning of the mechanisms of use of the mouse, of the menus, of the toolbars and of all the classical operational functionality of Windows.
1.1.2 Conventions adopted in the manual

The following conventions have been adopted in the present manual:

- the description of a Command and an Item or a sub-item of a Menu has been put in evidence as shown in the examples that follow, adopting the following criterion:
  a) sketch of the Button, when it is available
  b) combination of the short cut keys, when available
  c) title of the operation (in bold type) followed by the description of how to access to the Item or Sub-item of Menu that the operator wants to select
  d) after this, an explanation is given of what happens after the execution of the command or the item of menu and in the case what other actions should be undertaken for completing it

Complete example of button, short cut key, etc.:

<table>
<thead>
<tr>
<th>Button</th>
<th>Create a new list</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+N</td>
<td>Choose item New in File menu.</td>
</tr>
</tbody>
</table>

Description of the command.

If no button is associated to the operation, then the situation will be:

<table>
<thead>
<tr>
<th>CTRL+N</th>
<th>Create a new list</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Choose item New in File menu.</td>
</tr>
</tbody>
</table>

Description of the command.

If neither a button nor a short cut key is associated to the operation, then the situation will be:

<table>
<thead>
<tr>
<th>Create a new list</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose item New in File menu.</td>
</tr>
</tbody>
</table>

Description of the command.

- in the description of a Button, belonging to a Toolbar, the sequence Menu / Item / Sub-item of the correspondent literal menu is indicated in brackets “{}”
• in some cases, the names of push buttons are placed between square brackets, in bold type (ex. [Cancel]).

1.1.3 The work environment

The work environment is constituted by a Main Window where we find the Menus and the Toolbar and by several Secondary Windows, these last representing each one a different operational environment.

The window in which user is operating is called Active Window and the menu items that in that situation have no effect are disabled.

1.2 The Genesis window

The main window of Genesis at start up shows the Toolbar and the Menu Bar, and it is quite similar to the standard windows of other applications for Windows.

fig. 1.1: The structure of Genesis window

In this section the main elements of the window of Genesis are described, as the Menus, the Toolbar and the Status Bar.
1.2.1 Structure of the Genesis window

As in all programs running under Windows, the Genesis window is characterised by areas with different functionality; beginning from top:

- **Bar of the Title** contains the name of the lines opened in the active window.

- **Bar of the Menus** contains the various menus gathered for categories; every menu is composed by a series of items offering the different operational possibilities and that are in some cases associated to the buttons present on the Toolbar, as explained in the following point.

- **Toolbar** contains the buttons for the immediate selection of some functionality of more frequent use; naturally these functionalities may also be activated by the menu

- **Work Area** devoted to the visualisation of the open secondary windows.

- **Status Bar** contains some types of messages and the state of some keys.

- **Errors Bar** shows the last error or the last message generated during the execution of the program.

1.2.2 The Title Bar

The Title Bar contains the name of the active application and some push buttons for controlling the main window.

![The Title Bar](image)

**fig. 1.2:** The Title Bar

The meaning of the different fields is the following:
### N. Content Description

1. **Icon**  
   push-button for access to *Control Menu*.

2. **Title**  
   shows title of the active window followed by name of the open file, within square brackets.

3. **Minimise**  
   push-button for minimising the window; in case window is already minimised, it is substituted by a push-button representing a single window; pushing it, the window is enlarged.

4. **Maximise**  
   push-button for maximising the window.

5. **Close**  
   push-button for closing the window.

**NOTE:** In case Genesis is activated in “Protected” mode, (defined by machine builder) the possibility to minimize or iconize the main window is disabled. It’s also impossible to pass to other Windows programs already open by means of ALT+TAB. When closing Genesis, also Windows gets closed.

#### 1.2.3 The Menu Bar

It contains the names of the available menus, showing the various items associated to each of them, corresponding to executable commands or windows for data setting.

On the opposite sides of this bar, a set of push-buttons is located, similar and with the same functions of the ones located on the title Bar.

Once the name of a menu is selected, a pop-up menu is opened with the list of the available items.

An item may be selected with mouse or keyboard:

**Mouse**  
Locate mouse cursor on the title of the desired menu and click left button: the menu items appear. Repeat the operation for selection of the menu item.

**Keyboard**  
1. Push ALT key or F10 followed by the letter underlined in the desired menu title.
2. When the menu appears, push the key corresponding to the letter underlined in the desired command.
3. Alternatively, You can place the highlighter bar on the command using arrow keys, and confirm pushing ENTER.
A specific menu, existing in every Windows page, is the Control Menu, allowing the operator to Restore, Displace, Close, Resize the current window.

Control Menu may be selected as follows:

**Mouse**  
click the case of Control Menu

**Keyboard**  
push ALT key followed by SPACE BAR.

### 1.2.4 The Toolbar

This bar contains some buttons that provide quick access to the commands and the tools of most frequent use; it contains also two boxes that are related to the list of execution of the programs.

### 1.2.5 Work Area

This is the area of the main Window in which are contained the secondary windows open, whose content depends on the specific application that they represent.

On the right and bottom sides of every window, Slide Bars may appear, that allow panning the screen, in order to show parts of the window that are not visible.

Within every secondary window, other windows can be opened, according to the type of operation under execution, called dialogue windows. Each of them has its specific composition and may contain, for instance: text boxes, control boxes, option buttons, command buttons and others.

In order to position on the various elements of this type of window with the keyboard, one must use the followings keys:

- **TAB** to pass to the following item
- **SHIFT+TAB** to come back to the preceding

In text boxes, normally used for data introduction, data are confirmed by passing to another item in the window.
1.2.6 The Errors Bar

This bar contains in the left box the description of the last cycle error (on yellow background) or system error (on red background), in the right box is the total number of errors is displayed.

1.2.7 The Status Bar

This bar appears in the bottom area of the Main Window; it shows messages and the state of some keys:

<table>
<thead>
<tr>
<th>N.</th>
<th>Content</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Messages</td>
<td>it shows the description related to the menu item selected or the last message from the program under execution or other information.</td>
</tr>
<tr>
<td>2.</td>
<td>Line in execution</td>
<td>it shows the number of the line of the List currently in execution.</td>
</tr>
<tr>
<td>3.</td>
<td>Current Line of the list</td>
<td>it shows the number of the current line of the List of execution.</td>
</tr>
<tr>
<td>4.</td>
<td>Caps Lock Key</td>
<td>it shows the state of this key.</td>
</tr>
<tr>
<td>5.</td>
<td>Num Lock Key</td>
<td>it shows the state of this key.</td>
</tr>
<tr>
<td>6.</td>
<td>Scroll Lock Key</td>
<td>it shows the state of this key.</td>
</tr>
<tr>
<td>7.</td>
<td>Insert Key</td>
<td>it shows the state of this key.</td>
</tr>
</tbody>
</table>

fig. 1.2: The Status Bar.

Each field represented in fig. 1.2, contains:

1.2.8 How to activate or hide the Bars

The Bars, all present at Genesis start up, can be hidden and subsequently reactivated in the following way:
### Toolbar
- Choosing from the menu **View** the item **Toolbar**.

The command reverses the situation of the Toolbar, hiding it if visualised and back.

### Status Bar
- Choose item **Status Bar** in **View** menu.

The command reverses the situation of the Status Bar, hiding it if visualised and back.

### Errors Bar
- Choose item **Errors Bar** in **View** menu.

The command reverses the situation of the Bar of the errors, hiding it if visualised and back.

#### 1.2.9 Selection of the desired operation

Access to the operation that one desires to effect, is got in most cases in three different ways:
- bring the mouse on the button in the Toolbar and click the left key
- or
- use the short cut keys indicated in the item of menu
- or
- open the menu and select the desired item
1.2.10  The operating windows of Genesis

The operating windows are of different types, they depend on the type of operation that user intends to develop and can be kept open contemporarily; it is therefore possible to open for instance the window of the List of execution of a module and the Diagnostic window of another module. The windows may be divided in the following basic types:

<table>
<thead>
<tr>
<th>Window</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main</td>
<td>from which the other windows may be opened.</td>
</tr>
<tr>
<td>Synoptic</td>
<td>contains a graphic representation of the machine or of its parts, allowing to operate on them.</td>
</tr>
<tr>
<td>List of execution</td>
<td>it is the List of the programs that must be executed.</td>
</tr>
<tr>
<td>Diagnostic</td>
<td>it provides visualisation of devices status, in some cases it is also possible to operate on them.</td>
</tr>
</tbody>
</table>

Other types of windows are possible, but these are the most usual. As already mentioned, every window offers different Menus, suitable for the type of operations that can be effected in that window, while the Status Bar remains always the same. The description of the Buttons of the Bar and of the Menu Items will be presented during the treatment of the various functionalities.

In the Toolbar, the Buttons are gathered according to the Menu to which they belong, or to the same type of functionality.

In the Menus, the symbol ✓ (check mark) beside an Item or Sub-item (or Command), points out that that command is active.

In every window, according to the different commands selected, other dialogue windows are opened allowing insertion, edit and visualisation of data.

The **Main Window** (fig. 1.1) opens at Genesis start up; in this moment the number of menus and the items enabled are reduced format, as no other windows are open. During the operations, the menus are updated according to the active window.
1.2.11 Genesis Menus

As already described, each of the windows has its own Menu Bar, whose items mostly represent commands. Yet it is possible that a menu contains names of scroll-down menus (the so-called Sub-items, whose presence is marked by a triangle beside the item), also containing other commands, or a list of windows.

When they are not necessary or not available, some menu items are deactivated; in this case also the corresponding buttons on the Toolbar have the same treatment.

This behaviour usually depends from current access level.

The names of all the menus are listed hereafter, with a short description.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lines</td>
<td>to create, open, save, close and print.</td>
</tr>
<tr>
<td>Edit</td>
<td>to effect operations of editing.</td>
</tr>
<tr>
<td>View</td>
<td>to select the visualisation of the bars, devices, errors and other.</td>
</tr>
<tr>
<td>Debug</td>
<td>to access to the debug tools and commands.</td>
</tr>
<tr>
<td>Automatic</td>
<td>to access to the commands for the execution of programs.</td>
</tr>
<tr>
<td>Options</td>
<td>to access to some options.</td>
</tr>
<tr>
<td>Test</td>
<td>to access to test functionality and commands.</td>
</tr>
<tr>
<td>Cnc</td>
<td>to initialise the connection between Genesis program and the hardware.</td>
</tr>
<tr>
<td>Tools</td>
<td>to execute external programs.</td>
</tr>
<tr>
<td>Window</td>
<td>to organise the windows and give focus to one of the open windows.</td>
</tr>
<tr>
<td>?</td>
<td>to access to the Help window or to get information about Genesis.</td>
</tr>
</tbody>
</table>

The Toolbar is composed by six groups of buttons. The active buttons are naturally those that allow operations available in the current window.

![fig. 1.4: The Toolbar.](image)

*Repetitions* box, is only available if the application requires it.
1.3 General commands

1.3.1 Close the current window

The current window can be closed as follows:

<table>
<thead>
<tr>
<th>Close the current window</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item Close in File menu.</td>
</tr>
</tbody>
</table>

Before closing a window, if any modification has not yet been saved, a dialog box appears allowing saving. When the window is closed, the next active window appears.

1.3.2 Exit Genesis

Once work is completed, one can exit Genesis as follows:

<table>
<thead>
<tr>
<th>Exit</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item Exit in File menu.</td>
</tr>
</tbody>
</table>

Before terminating, Genesis closes all open windows; in case of modifications not yet saved a window is displayed allowing saving. When opened next time, Genesis will re-open all windows that were open at closure.

1.3.3 Character setting

For each type of text used in visualisations, the type of character may be selected, with its attributes, as follows:

<table>
<thead>
<tr>
<th>Character setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item Font in menu Options.</td>
</tr>
</tbody>
</table>

The standard Windows dialogue box appears, for the choice of character font and dimension.

1.3.4 Arranging windows

The open windows may be arranged as follows:
1.3.5 **Arrange icons**

The active window may be enlarged up to full screen dimensions, or reduced to icon if the operator prefers leaving only the currently used windows open. Reduction to icon allows an easy re-opening of the window.

Icons may aligned on the screen with command:

**Arrange Icons**

- Chose item **Arrange Icons** in menu **Window**.

Icons are horizontally aligned in the work area.

1.3.6 **Change the active work window**

In the bottom of the **Window** menu a list appears of the open windows. A window may be activated by double clicking with mouse on its name, if visible, or selecting it in the menu as follows:

**Select the active work window**
• Choose the desired window title in the **Window** menu.

The selected window is put in foreground and becomes active.

### 1.3.7 Guide of *Genesis*

The Guide Menu of *Genesis* provides the following commands:

<table>
<thead>
<tr>
<th><strong>Open the guide</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose <em>On Line Guide</em> in menu?</td>
</tr>
</tbody>
</table>

The window of the On Line Guide appears.

<table>
<thead>
<tr>
<th><strong>Use of the guide</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose <em>Use of Guide</em> in menu?</td>
</tr>
</tbody>
</table>

The window of the Use of Guide appears.

<table>
<thead>
<tr>
<th><strong>Information on <em>Genesis</em></strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose <em>About Genesis</em> in menu?</td>
</tr>
</tbody>
</table>

Displays information concerning *Genesis* version and system resources.
**Introduction**

**GENESIS - Operator Manual**

<table>
<thead>
<tr>
<th>HELP ONLINE</th>
<th>SHIFT+F1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Press the button located in Toolbar.</td>
<td></td>
</tr>
</tbody>
</table>

Mouse cursor takes the shape of the button, move it on the item whose Help should be displayed and click with right button of mouse. Close the operation by pressing again the button or key ESC.
2. SYSTEM COMPOSITION

2.1 Foreword

Since many features, in the graphic representations and in the structure of the data base of the Machine, strongly depend from the typology of the Machine itself, further to some general information, this Manual provides a description of the composition of the system in the present application.

The real indications, the schemes and the graphic pages of the real system depend obviously on the specific application, and are provided by the Builder of the Machine Tool.

2.2 Architecture of a typical Genesis system

The Genesis numerical control is constituted by a Control Unit, based on a PC in industrial version, that represents the interface Operator/Machine, and by a variable number of mainframe modules (from 1 to 16), for driving and controlling all the operational resources of the Tool Machine.

Two versions are available:

- **Monomodule** constituted by a single module directly connected to PC bus
- **Multimodule** constituted by a minimum of 1 up to a maximum of 8 modules and suited for Plants or Lines with many machines; the PC unit in this case is normally separated by the Mainframe Modules, located in different points of the Plant or Line.

In both architectures, the mainframe modules are constituted by multiprocessor boards for the direct control of the Machine Axes and the logical management of the Input/Output devices. These last are driven, at physical level, from intelligent devices directly located on the machine; these devices provide continuous monitoring of the Digital (On/Off) and Analogue Input lines and refreshment of the Digital and Analogue Output lines and are connected to the Mainframe through a 1 Mbaud RS485 serial bus.
2.3 **Organisation and logical configuration**

In the Genesis system, the descriptive structure of the Tool Machine is organised in a technological file with a tree hierarchical structure, in such a way to facilitate and make more immediate and intuitive the access to the physical resources of the system, in the different phases of programming, of execution and of supervision or diagnostic control.
This formulation reflects the demand to preserve, for what concerns configuration data and formality of access, the modular structure of the machines, classifying it in terms of dynamic aggregation of different groups, modules and devices, that may be inserted or excluded in the different available versions of the machine.

Following this logical structure, in the most general and complex case, we have the top hierarchical level constituted from:

- **Plant** normally intended as the whole set of operating systems controlled by the Numerical Control, subdivided into:
  - **Machines** normally intended as the operational elements that are acting on the piece to be worked; they are constituted by a number of
  - **Groups** intended as operational modules that can operate in the same time and independently within the same machine; they may be composed by
  - **Subgroups** intended as operational modules that can operate in the same time and independently within the same Group and composed by
  - **Devices** intended as the whole of all those elementary, physical or logical elements, that have an univocal correspondence with resources of the control, as
    - Axes
    - Digital Input/Output
    - Analogue Input/Output
    - Logical resources (Counters, Timer, Variables, Subroutines, Functions, etc.)

**Note:** The Groups may also be not subdivided into Subgroups, and may be composed directly by Devices.

In the case of a single machine, this structure can be brought to a simplification, eliminating the upper hierarchical layers, as the Plant Level.

Thus the structure of the Machine Data Base, in its maximum configuration, has normally the followings levels:
### System Composition

**GENESIS - Operator Manual**

#### Plant Composition

<table>
<thead>
<tr>
<th>Level</th>
<th>Level</th>
<th>Level</th>
<th>Level</th>
<th>Level</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant</td>
<td>Machine</td>
<td>Group</td>
<td>Subgroup</td>
<td>Devices</td>
<td></td>
</tr>
</tbody>
</table>

**Plant Name**

Machine 1

- **Group 1**
  - Subgroup 1: Input
    - Output
    - I/O Analogue.
    - Axes
    - etc.
  - Subgroup 2: idem

- **Group 2**
  - Subgroup 1: Input
    - Output
    - I/O Analogue.
  - Group n: Axes
    - etc.

Machine 2

- **Group 1**
  - Subgroup 1: Input
    - Output
    - I/O Analogue.
    - Axes
    - etc.

Machine 3

- **Group 1**
  - etc.
  - Subgroup 1: Input
    - Output
    - I/O Analogue.
    - Axes
    - etc.

**fig. 2.2:** Example of the system hierarchical organisation
2.4 The Devices

For device we mean a physical or logical element, that composes the system and has an univocal correspondence with one of the resources of the control. The devices can be grouped in two categories: physical devices and logical devices. In the system, all the devices are qualified by a name that identifies their use.

2.4.1 Physical devices

For physical devices we intend all those elements that act on the electric or pneumatic parts of the machine or that detect their status; specifically:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Device</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="symbol" alt="Digital Input" /></td>
<td>Digital Input</td>
<td>detects the status ON or OFF of a device.</td>
</tr>
<tr>
<td><img src="symbol" alt="Digital Output" /></td>
<td>Digital Output</td>
<td>Activates or Deactivates a device, setting it in the status On or Off.</td>
</tr>
<tr>
<td><img src="symbol" alt="Analogue Input" /></td>
<td>Analogue Input</td>
<td>it reads the value assumed by the device.</td>
</tr>
<tr>
<td><img src="symbol" alt="Analogue Output" /></td>
<td>Analogue Output</td>
<td>sets a certain value to an analogue device.</td>
</tr>
<tr>
<td><img src="symbol" alt="Input Port" /></td>
<td>Input Port</td>
<td>is composed by 8 lines of digital inputs.</td>
</tr>
<tr>
<td><img src="symbol" alt="Output Port" /></td>
<td>Output Port</td>
<td>is composed by 8 lines of digital outputs.</td>
</tr>
<tr>
<td><img src="symbol" alt="Input Nibble" /></td>
<td>Input Nibble</td>
<td>is composed by 4 lines of digital inputs.</td>
</tr>
<tr>
<td><img src="symbol" alt="Output Nibble" /></td>
<td>Output Nibble</td>
<td>is composed by 4 lines of digital outputs.</td>
</tr>
<tr>
<td><img src="symbol" alt="Axis" /></td>
<td>Axis</td>
<td>manages the displacement of an electrical axis.</td>
</tr>
</tbody>
</table>
### Logical devices

The logical devices are elements that act exclusively within the work programs and allow to perform all the operations of drive and control on the physical devices; they are:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Device</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="timer" /></td>
<td>Timer</td>
<td>element for counting time.</td>
</tr>
<tr>
<td><img src="image" alt="counter" /></td>
<td>Counter</td>
<td>element for counting operations.</td>
</tr>
<tr>
<td><img src="image" alt="flag" /></td>
<td>Flag bit</td>
<td>Flag that may be set On or Off only within a work program.</td>
</tr>
<tr>
<td><img src="image" alt="flag" /></td>
<td>Flag switch</td>
<td>System Flag that may be set On or Off by system, and not only within a work program, as for instance Start flag.</td>
</tr>
<tr>
<td><img src="image" alt="flag" /></td>
<td>Flag port</td>
<td>Composed by 8 flag Lines.</td>
</tr>
<tr>
<td><img src="image" alt="function" /></td>
<td>Function</td>
<td>is the elementary unit that together with other functions composes a program and it constitutes the logical control device inside which, through special instructions, all the functionalities of control and management of the other devices are executed.</td>
</tr>
<tr>
<td><img src="image" alt="variable" /></td>
<td>Variable</td>
<td>element that contains a type of data in the case of simple variable, or different data types in case of composed variable.</td>
</tr>
</tbody>
</table>
3. EXECUTION LIST

3.1 Preliminary

The execution of the working programs is implemented, usually, through a List of Execution; the list may include a number of lines, one for each program, and some columns to define the different modalities of execution for every program.

Every line of the list allows entering, in the different columns, all the information, data and parameters required for the execution of the program. The number and meaning of the different columns may change according to the different applications, but the first column, with the program name, is always present.

NOTE: An Genesis operating mode, called “Autoload” and defined by machine Builder, allows automatic loading of a pre-defined execution List. In this case some commands of File menu are disabled (for instance Open, Save, Save with name). List content may be edited and saved.

If Genesis doesn’t find a list when it tries to open it, it creates a new one empty.

3.2 Creation of a List

3.2.1 Create a new list

The creation of a new list is effected in the following way:

CTRL+N

- Choose item New in File menu.

A new list is opened, with the temporary name of “list” followed by a number (ex. List1); opening another new list, this number is automatically incremented by 1. In phase of saving, the desired name may be applied to file. After opening the new list or an existing list, the window “List in execution” will appear; an example can be seen in fig. 3.1.
3.2.2 List Properties

The following properties are associated to a list:

<table>
<thead>
<tr>
<th>ALT+ENTER</th>
<th>List Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Choose item <strong>Properties</strong> in <strong>File</strong> menu.</td>
</tr>
</tbody>
</table>

A window appears with the following information:

*Description* shows list comment and allows editing it.

*Version* contains version number of list file.

3.2.3 Composition of window “Execution List”

This window is subdivided into lines and columns, each line referred to a program to be executed and each column containing the information required for its execution.

The window is composed by the following elements:

- **Program Name/List Area**
  - contains selection buttons with line number, each one followed by a box, where *program name* or *list name* should be inserted

- **Parameters Area**
  - contains columns constituted by boxes containing parameters conditioning program execution.

- **Push-buttons Area**
  - on the lower side, it contains three push-buttons giving immediate access to some commands also available in Menu:
    - [**New**] creates a new line under the current line
    - [**Delete**] deletes all the lines selected
    - [**Properties**] activates window Properties

- **Other areas**
  - contains a text box that is located on the Toolbar and is not part of the Execution List, but contain the *Repetition Number* of the active list.
A detailed explanation of the meaning of the various columns composing the Execution List of Genesis is provided at the end of the chapter, together with other information concerning its execution on the working areas.

3.3   Filing a list

3.3.1   How to save a list

A list may be filed as follows:

<table>
<thead>
<tr>
<th>CTRL+S</th>
<th>Save active list</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Choose item Save in File menu.</td>
</tr>
</tbody>
</table>

Normally, a list is immediately saved after this command. In case of a new list, a window appears, allowing substitution of the temporary name with the real list name.
3.3.2 Create a new list while saving

A new list can be created while saving, deriving it from the active list, as follows:

<table>
<thead>
<tr>
<th>Save and create a new List</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item <strong>Save with name</strong> in <strong>File</strong> menu.</td>
</tr>
</tbody>
</table>

A window is appears, allowing introduction of the new List name. All the modifications introduced are saved, and the new List becomes active. The old list remains as it was after last saving.

List name may have a maximum of 8 characters, plus an extension of up to 3 characters (ex. DEMO.LSX). Standard extension is **LSX**, but a different extension may be used.

**Note:** This modality can be used for deriving a new list from an existing one, when many lists with similar contents should be generated.

3.4 Opening an existing list

A List can be opened in many ways; the first one is as follows:

<table>
<thead>
<tr>
<th>Open an existing List</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item <strong>Open</strong> in <strong>File</strong> menu.</td>
</tr>
</tbody>
</table>

A window appears allowing selection of the desired list.

A second way is as follows: if the list is one of the last four files recently opened, chose menu **File** and select its name in the list shown in the bottom.

A third way consists in writing the List name in the box **Program Name**.

**Note:** When a new or existing List is opened, the previous List remains open, and can be accessed by means of menu **Window**, by selecting its name in the list appearing in the bottom.

3.5 Print a List

3.5.1 Print a List

A List can be printed as follows:
3.5.2 Print preview

Print may be verified as follows:

<table>
<thead>
<tr>
<th>Print preview</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose item <strong>Print preview</strong> in <strong>File</strong> menu.</td>
</tr>
</tbody>
</table>

A dialogue appears, similar to standard Windows Print Preview. One or two pages may be displayed together.

3.5.3 Printer Setup

Printer characteristics may be set as follows:

<table>
<thead>
<tr>
<th>Printer setup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose item <strong>Printer setup</strong> in <strong>File</strong> menu.</td>
</tr>
</tbody>
</table>

The standard dialogue of Windows appears, allowing setting of printer type, paper orientation, etc.

3.6 How to operate on a list

The content of the various boxes of a List may be edited as described hereafter. The following terms will be frequently used:

- **current box** highlighted by a different colour and hatched border, this is the box that can be edited
- **current line** the line containing the current box
selected lines highlighted by a different colour, the corresponding buttons are lowered; if the current box is in one of these lines, it will remain hatched but assume the same colour of the line

3.6.1 Available keys

The following keys are available for editing on a List:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CursorUp</td>
<td>Upper box becomes current</td>
</tr>
<tr>
<td>CursorDown</td>
<td>Lower box becomes current</td>
</tr>
<tr>
<td>CursorRight</td>
<td>Right box becomes current</td>
</tr>
<tr>
<td>CursorLeft</td>
<td>Left box becomes current</td>
</tr>
<tr>
<td>PgUp</td>
<td>Scroll up one page</td>
</tr>
<tr>
<td>PgDn</td>
<td>Scroll down one page</td>
</tr>
<tr>
<td>Home</td>
<td>Go to first box in the list</td>
</tr>
<tr>
<td>End</td>
<td>Go to last box in the list</td>
</tr>
<tr>
<td>Ctrl+Up</td>
<td>Point to first box in the same column, in the active page</td>
</tr>
<tr>
<td>Ctrl+Down</td>
<td>Point to last box in the same column, in the active page</td>
</tr>
<tr>
<td>Ctrl+Right</td>
<td>Point to first box on the right in the same line, in the active page</td>
</tr>
<tr>
<td>Ctrl+Left</td>
<td>Point to first box on the left in the same line, in the active page</td>
</tr>
<tr>
<td>Ctrl+PgUp</td>
<td>Scrolls left the visible columns</td>
</tr>
<tr>
<td>Ctrl+PgDown</td>
<td>Scrolls right the visible columns</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Points to first box in first line</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>Points to last box in last line</td>
</tr>
<tr>
<td>Ctrl+Enter</td>
<td>Creates an empty line under the current line; the new line becomes current line</td>
</tr>
<tr>
<td>Shift+Ctrl+Enter</td>
<td>Creates an empty line above the current line; the new line becomes current line</td>
</tr>
<tr>
<td>Shift+Space</td>
<td>Select/Unselect current line</td>
</tr>
<tr>
<td>Shift+Up</td>
<td>Extends selection/unselection above the current line</td>
</tr>
<tr>
<td>Shift+Down</td>
<td>Extends selection/unselection under the current line</td>
</tr>
<tr>
<td>Shift+Right</td>
<td>Points to next box on the right</td>
</tr>
<tr>
<td>Shift+Left</td>
<td>Points to next box on the left</td>
</tr>
<tr>
<td>F2</td>
<td>Edit content of current box</td>
</tr>
<tr>
<td>Enter</td>
<td>Confirm modifications to current box</td>
</tr>
<tr>
<td>Esc</td>
<td>Cancel modifications to current box</td>
</tr>
<tr>
<td>Tab</td>
<td>Switch between List and push-buttons</td>
</tr>
<tr>
<td>Other ASCII chars</td>
<td>Are inserted in current box</td>
</tr>
</tbody>
</table>
### 3.6.2 Using mouse

Mouse is the most efficient tool for operating on a List; the available functions are described hereafter:

<table>
<thead>
<tr>
<th>Action</th>
<th>Position</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Box</td>
<td>Selects a box</td>
</tr>
<tr>
<td>Click</td>
<td>Line button</td>
<td>Selects/Unselects a line</td>
</tr>
<tr>
<td>Shift+Click</td>
<td>Box</td>
<td>Selects a box and Select/Unselect a line</td>
</tr>
<tr>
<td>Drag</td>
<td>Line button</td>
<td>Selects/Unselects lines</td>
</tr>
<tr>
<td>Double click</td>
<td>Box “Program Name”</td>
<td>Selects a box and shows the window “Program Name” for introduction of name, selected in the archive.</td>
</tr>
</tbody>
</table>

### 3.6.3 How to point to the selected box

A box can be selected, and become current, as follows:

1. click with mouse cursor on the desired box
2. use arrow keys UP, DOWN, RIGHT, LEFT
3. if the number of lines is greater than what is displayed in the window, scroll List using PgUp and PgDn keys or mouse on the window scroll bar
### 3.6.4 Selecting and unselecting a number of lines

A single line may be selected/unselected with keyboard or preferably with mouse. More lines can be operated together, for cutting, pasting, shifting, in order to group lines and so on.

There are two different ways of selecting more lines:

**Selection of non adjacent lines:**

1. Point on the line to be selected clicking with mouse on the selection push-button; this last will lower.
2. Repeat with the other lines to be selected.

**Selection of adjacent lines:**

1. Point on the first line to be selected clicking with mouse on the selection push-button; this last will lower.
2. Drag mouse on the other lines to be selected, under or above the current one, holding mouse left button.

The same procedure applies for unselection.

**Note:** For execution of the same operations with keyboard, make reference to the instructions concerning keys.

### 3.6.5 Selecting all lines

The following command is used for selection of all lines within List:

<table>
<thead>
<tr>
<th>Select all lines</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item <strong>Select all</strong> in <strong>Edit</strong> menu.</td>
</tr>
</tbody>
</table>

All lines within List become selected.
3.6.6 Unselecting all lines

The following command is used for unselection of all lines within List:

<table>
<thead>
<tr>
<th>Unselect all lines</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item <em>Select all</em> in <em>Edit</em> menu.</td>
</tr>
</tbody>
</table>

All lines within List become unselected.

3.7 Insertions and modifications in a List

3.7.1 Inserting new lines

New lines may be inserted under or above the current line, as follows:

<table>
<thead>
<tr>
<th>CTRL+SHIFT+ENTER</th>
<th>Insert a line before</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item <em>Insert before</em> in <em>Edit</em> menu.</td>
<td></td>
</tr>
</tbody>
</table>

An empty line is inserted before the current line.

<table>
<thead>
<tr>
<th>CTRL+ENTER</th>
<th>Insert a line after</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Choose item <em>Insert after</em> in <em>Edit</em> menu.</td>
<td></td>
</tr>
</tbody>
</table>

An empty line is inserted after the current line. The same command may be activated using push-button *[New]*.
3.7.2 Editing content of current box

Editing the content of the current box is possible after setting it in Edit mode; the box will lose its hatched border. After this, box may be edited as follows:

1. Push function key F2, text becomes right justified, cursor goes immediately after last character in box and the portion of text already present is highlighted with a colour different from the empty area. Then the content of box may be modified.
2. Digit on keyboard the text to be inserted; the previous content of box will be substituted by new text.
3. Push ENTER to confirm modifications and exit Edit mode. The same result may be achieved by pointing to a different box.
4. Edit mode may be interrupted by pushing ESC key; all modifications are lost.

**NOTE:** Some lines could result impossible to edit during List execution; this condition depends from the application.

3.7.3 Import from program archive

The name of program to be executed may be written in the corresponding box, either by digitising it, or with the following command:

<table>
<thead>
<tr>
<th>Import program name</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Chose item <strong>Open programs directory</strong> in <strong>File</strong> menu.</td>
</tr>
</tbody>
</table>

Window “Name” appears, allowing introduction of name, selected in the archive of the module or of other modules. Once a program is load from archive, the current line is automatically updated with all program data. These data are the parameters contained in the various columns of the list.

**Note:** This window can be opened also by **double clicking** on the selected box.

3.7.4 List of lists

A List can be inserted in another List; this functionality is called **List of Lists**. All lines composing this List are inserted in the active List, immediately after the current line; they are highlighted with a different colour and write protected; thus they cannot be edited, but they can be copied in other lines of the new list. New lines cannot be introduced within the lines of the List inserted.

If in box Repetitions, when present, a number greater than 1 is set, the List inserted in the current List is repeated according to this number.
3.8  Editing a list

All operations allowed on standard text are available also on a List: delete, copy, find, replace, and so on. The corresponding commands are described hereafter.

As 4 lines of the List are executed at a time, lines under execution cannot be edited, deleted, and other lines can’t be added within them.

3.8.1  Delete last operation

The following command may be used to cancel the last operation executed:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+Z</td>
<td>Delete last operation</td>
</tr>
<tr>
<td></td>
<td>• Chose item Delete in Edit menu.</td>
</tr>
</tbody>
</table>

The previous situation is restored.

3.8.2  Cut and save into memory

Selected lines may be removed and saved into the clipboard, as follows:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+X</td>
<td>Remove and copy to clipboard</td>
</tr>
<tr>
<td></td>
<td>• Chose item Cut in Edit menu.</td>
</tr>
</tbody>
</table>

The lines selected are removed from List and copied into the clipboard, allowing later use of command Paste, even in a different List.
### 3.8.3 Copy into memory

The following command can be used for copying the selected lines, or the content of the current box, into the clipboard:

<table>
<thead>
<tr>
<th>CTRL+C</th>
<th>Copy to clipboard</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>· Chose item Copy in Edit menu.</td>
</tr>
</tbody>
</table>

The lines selected are copied into the clipboard, allowing later use of command Paste, even in a different List. If command is activated while editing the current box, only the content of this box will be copied into the clipboard.

### 3.8.4 Copying from memory

The following command can be used for copying the content of the clipboard into the List:

<table>
<thead>
<tr>
<th>CTRL+V</th>
<th>Paste from clipboard</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>· Chose item Paste in Edit menu.</td>
</tr>
</tbody>
</table>

The content of the clipboard in inserted in the List, with the following rules:

- if one is editing the current box, and some lines are stored in the clipboard, the content of the current box is substituted by the content of the first box within the lines stored (thus the program name, in our examples).

- if one is editing the current box, and the content of another box is stored in the clipboard, this last is placed in the current box only if the data type is the same.

- if one is not editing the current box, and some lines are stored in the clipboard, these lines are placed in new lines after the current line.

This command may be used, for instance, to introduce a portion of a List in another List.

**Note:** the content of the clipboard is not deleted when a List is closed; memory is cleared when exiting Genesis.

### 3.8.5 Delete

The following command can be used for deleting:
3.8.6  Find

The following command can be used for searching in the current List:

<table>
<thead>
<tr>
<th>ALT+F3</th>
<th>Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Find</strong> in <strong>Edit</strong> menu.</td>
<td></td>
</tr>
</tbody>
</table>

A window appears, helping the introduction of what one is searching and the criteria to be used during search.

The following push-buttons allow starting or stopping search:
- [Find next] allows starting or restarting search.
- [Cancel] terminates search.
- [?] opens help window.

After completing search, if text is not found, the box containing text is highlighted; pushing button [Cancel] this box is set into Edit mode.

3.8.7  New search

Once a search has been set, new searches may be effected as follows:

<table>
<thead>
<tr>
<th>F3</th>
<th>New search</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Find next</strong> in <strong>Edit</strong> menu.</td>
<td></td>
</tr>
</tbody>
</table>

Search is effected; if text is found, the corresponding box is highlighted; by pushing [Cancel] the box is set to edit mode.

3.8.8  Replace

Portions of a List may be replaced as follows:
Replace
- Chose item **Replace** in **Edit** menu.

A window appears, helping the introduction of what one is searching, the text to replace and the criteria to be used during search.

The following push-buttons allow starting or stopping search:

- **Find next**  
  - don’t replace, start a new search.

- **Replace**  
  - replace and start a new search.

- **Replace all**  
  - automatically effect all possible replacements.

- **Cancel**  
  - terminate search.

- **?**  
  - open help window.

3.9 **Other commands available**

3.9.1 **Protect a List**

A List may be protected against unintentional editing. This can be done with the following command:

Read only
- Chose item **Read Only** in **Edit** menu.

List is set in Read Only mode until command Read Only is deactivated or the List is closed. When opening a List, it is never in Read Only mode.
3.9.2 Repeat a List

Number of repetitions of a List may be set as follows:

<table>
<thead>
<tr>
<th>CTRL+R</th>
<th>Repeat List</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Chose item Repeat in Edit menu.</td>
</tr>
</tbody>
</table>

A window appear, helping introduction of the number of times the List should be executed. Number of repetitions will appear in the box on the right side of Toolbar.

Note: Number of repetitions may be set directly in the corresponding box in Toolbar; pointing on it with mouse a text cursor appears and clicking mouse text can be modified; this is not allowed during List execution, when this box shows the number of repetitions already executed.

3.10 List Execution

Once a List has been edited or recalled from archive, it may be put into execution, selecting the first line (that means the first program) to be executed and pushing Start. This line is not necessarily the first. Commands for controlling execution may be directly accessed by means of the corresponding push-buttons in the Toolbar.

If a starting line is not selected, the system will automatically assume as first line to be executed the first line in the List containing a repetition number greater than 0 and box Enable active (if existing in the List).

The line corresponding to program in execution is highlighted in red colour. If list should be repeated, the number of repetitions is automatically updated - decremented - each time List is executed.

During execution, error or warning messages are displayed in the Error Bar or in the Status Bar.

List execution may be temporarily suspended and restarted.
3.10.1 Control of execution

Start execution

The following command starts program execution, or restarts after a stop:

<table>
<thead>
<tr>
<th>F5</th>
<th>Start or restart execution</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Chose item Start in Automatic menu</td>
</tr>
</tbody>
</table>

Program execution starts and the corresponding line is highlighted in red colour. After a Stop, execution restart from the point where it had been suspended.

Stop execution

Program execution may be temporarily suspended with the following command:

<table>
<thead>
<tr>
<th>F6</th>
<th>Stop execution</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Chose item Stop in Automatic menu</td>
</tr>
</tbody>
</table>

Program execution is suspended until a new Start command.

End execution

Program execution may be interrupted with the following command:

<table>
<thead>
<tr>
<th>F7</th>
<th>End execution</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Chose item End in Automatic menu</td>
</tr>
</tbody>
</table>

Program execution and List execution are ended.
**Toggle Start line**

List execution can be started from any line in the List using the following command:

<table>
<thead>
<tr>
<th>Set Starting line</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Toggle Start line</strong> in <strong>Automatic</strong> menu.</td>
</tr>
</tbody>
</table>

This command sets the current line as first line to be executed. If list has a number of repetitions, after execution system restarts from first line.

**Enable line**

If allowed by the application, one or more lines of the execution list may be disabled and then enabled again, by means of the following commands:

<table>
<thead>
<tr>
<th>Enable a line</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Enable line</strong> in <strong>Automatic</strong> menu.</td>
</tr>
</tbody>
</table>

Select lines and then enable them with this command.

**Disable line**

<table>
<thead>
<tr>
<th>Disable a line</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Disable line</strong> in <strong>Automatic</strong> menu.</td>
</tr>
</tbody>
</table>

Select lines and then disable them with this command.
Mark line as executed

This command allows marking a line in the List as already executed, when the application allows this functionality:

<table>
<thead>
<tr>
<th>Mark line as executed</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Mark line as executed</strong> in <strong>Automatic</strong> menu.</td>
</tr>
</tbody>
</table>

The current line is marked as executed, even if not yet executed.

Simulate execution

This command allows executing a List in simulation, when the application allows this functionality:

<table>
<thead>
<tr>
<th>Simulate execution</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Simulation</strong> in <strong>Automatic</strong> menu.</td>
</tr>
</tbody>
</table>

List is executed in simulation, according to the functionality provided by the application.

Setpoint execution

This command allows execution of Set Point, when the application allows this functionality:

<table>
<thead>
<tr>
<th>Setpoint execution</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <strong>Setpoint</strong> in <strong>Automatic</strong> menu.</td>
</tr>
</tbody>
</table>

Setpoint is executed.
### 3.10.2 Displays during execution

During execution, some events may happen that originate three different types of messages:

- **System errors**: fatal errors terminating program execution, marked with red colour; description of these errors is provided in a specific manual.
- **Cycle errors**: errors happening during program execution, allowing its continuation after removing error; marked with yellow colour.
- **Messages**: warning messages generated in some special situations during execution, or inviting the operator to operate on the machine; they don’t stop program execution.

Errors are displayed on the *Error Bar* if this is active, while messages are displayed on the *Status Bar*.

All errors are stored in a file for history log. Errors generated after last machine was switched on are displayed in a window that can be opened by double clicking mouse on the *Error Bar* or using the three commands within menu *View* described later.

**Note:** Error messages displayed in the window are more detailed with respect to those displayed in the *Error Bar*.

<table>
<thead>
<tr>
<th>Display system errors</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item <em>System errors</em> in <em>View</em> menu.</td>
</tr>
</tbody>
</table>

A window appears showing the last 100 system errors, sorted in time order starting from the last generated, marked in red colour. This window is subdivided into the following fields:

In the **top** these information are displayed.

- **Time&Date**: time and date when the error happened.
- **Description**: is the error description.
- **Titleless column**: is the number of error message.
- **Task**: is the name of task that generated error (not present in the Error Bar).

By double clicking on one of these columns, information are sorted according to the content of column. In the bottom side the following boxes are present:

- **Cycle errors**: when activated, also these errors are shown, marked in yellow.
**Messages** when activated, also messages are shown.

All when activated, all messages from all modules in the system are shown, in connection with the type of information currently displayed.

Field *module name* shows name of module currently displayed, allowing also selecting, in case of system with many modules, the module whose information should be displayed.

A number of Push-buttons are displayed, with the following meaning:

- [ Delete all ] deletes all information displayed, without removing them from archive.
- [ Delete ] deletes information currently displayed, without removing them from archive.
- [ OK ] closes window

**Display cycle errors**

- Chose item *Cycle errors* in View menu.

A window appears showing the last 100 cycle errors, sorted in time order and marked in yellow colour. Same functionality as for System Errors.

**Display Messages**

- Chose item *Messages* in View menu.

A window appears showing the last 100 cycle errors, sorted in time order and not marked with colour. Same functionality as for System Errors.
3.11 List Manager

The List Manager controls the machine while in Automatic. From here we specify which programs are executed and in which fields.

There are a minimum of six fields on each Busellato Machining Center.

These are:

"N" This is the normal field. This field extends from the left of the machine to the right. Original image, (non mirrored), parts are processed here and the vacuum pods are used across the entire length of the machine. Only 1 part can be loaded to be ran on a standard machine in each cycle.

"M" This is the mirror field. This field extends from the right of the machine to the left. Mirrored parts are processed here and the vacuum pods are controlled for entire length of the machine. Only 1 part can be loaded to be ran on a standard machine in each cycle.

"S" This is the standard field. Original image parts are processed here using the same reference as "N". Only the vacuum cups on the left side of the machine, usually 1/2 of the total panel supports are used so the right hand side of the machine can be loaded alternately.

"A" This is the alternate field. This field produces mirror image parts. The reference for this field is just to the left of center of the machine. Only the vacuum cups on the left side of the machine are used so more than one part be processed.

"T" This is the transposed field. Original image parts are processed in this field. The reference for this field is just to the right of center of the machine. Only the vacuum cups on the right side of the machine are used so more than one part can be processed.

"R" This is the reversed field. This field produces mirrored parts. The reference for this field is the same as "M". Only the vacuum cups on the right side of the machine are used so more than one part can be processed.
Some machines have optional forward fields in addition to the standard fields.

The following images have hotspots that will cause a hand to appear if there is information about that item. Click once to see the information about a particular item when the hand appears, then again to close the pop-up window.

**fig. 3.2:** Composition of execution list.

**Name**

This is where the name of the program is displayed. Selecting FILE,NEW will cause the cells, (boxes), to appear, then the space under Name can be double clicked to bring up an index of available programs. Please notice that programs can be loaded into the List Manager from a networked computer as well as the local hard drive.

**Num**

Number of repetitions of program.
**Area**

Working field where program should be executed; constituted by a selection list, where the correct field can be chosen.

**Execute**

This checkbox can be used to skip one program or more in a list.

**L, H, T**

This is the length, height, and width of the programmed panel. These can be modified in the List Manager without changing the original stored program in order to utilize parametrically written programs.

**Comment**

This is the comment that is stored with the program.

**Stack**

This checkbox allows two or more programs to be executed in the same field without the vacuum pods releasing the part.

**Exclusions**

This is where exclusion numbers, (1-8), can be put to exclude program lines that have been assigned in the program lines.

**Time**

This is where the actual execution time of the programmed panel is displayed after it is ran the first time. Each time the part is ran the time is averaged in order to be as accurate as possible.

**Variable**

This is where variables are displayed if they are used in the program. These can be changed to modify a program in the List Manager without changing the original program. These are a, b, c, d, e, f, g, and i.

### 3.12 Definition of working fields and working codes

Automatic execution mode allows execution on different working fields, in order to reduce working time for mirror pieces, without need of program duplication. Machine may be most efficiently operated using four different fields, with no limits concerning the possibility to combine adjacent fields.
The four working fields are defined as described in the following graphic outline:

<table>
<thead>
<tr>
<th>#</th>
<th></th>
<th>#</th>
<th></th>
<th>#</th>
</tr>
</thead>
<tbody>
<tr>
<td>FIELD S</td>
<td>FIELD A</td>
<td>FIELD T</td>
<td>FIELD R</td>
<td></td>
</tr>
</tbody>
</table>

The External border represent working plane.

The four # symbols represent mechanical references, against which the piece should lean. Starting from the first left reference, they are identified as:

a) reference for workings N and S  
b) reference for workings N  
c) reference for workings T  
d) reference for workings M and R

The meaning of this workings is described later in this Chapter.

A quarter of the XY plane is assigned to each of the four fields.

Fields S and T are normal working fields:

program execution reflects programming schedule, with origin on the left side of the machine and X co-ordinates growing towards right side.

Fields R and A are mirror working fields:

program execution reflects programming schedule, mirrored on X axis. Origin at execution time is mirrored on the right side of the machine, with X co-ordinates growing towards left side.
3.13 **Execution modes on working fields**

In the four above mentioned working fields, the following working modes are allowed.

36 different execution modes may be specified.

With reference to the graphic sketch of XY plane, the execution modes are:

<table>
<thead>
<tr>
<th>N</th>
<th>A</th>
<th>T</th>
<th>M</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>#</td>
<td>#</td>
<td>#</td>
</tr>
<tr>
<td>A1</td>
<td>A2</td>
<td>A3</td>
<td>A4</td>
</tr>
<tr>
<td>N long</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>N short</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>S long</td>
<td>A1</td>
<td>A2</td>
<td></td>
</tr>
<tr>
<td>S short</td>
<td>A1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T long</td>
<td>A1</td>
<td></td>
<td>A3</td>
</tr>
<tr>
<td>T short</td>
<td></td>
<td>A3</td>
<td></td>
</tr>
<tr>
<td>M long</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>M short</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>R long</td>
<td>A4</td>
<td>A3</td>
<td></td>
</tr>
<tr>
<td>R short</td>
<td>A4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A long</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>A short</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>A1</td>
<td>A2</td>
<td>A3</td>
<td>A4</td>
</tr>
<tr>
<td>N long bis</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>N short bis</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>S long bis</td>
<td>A1</td>
<td>A2</td>
<td></td>
</tr>
<tr>
<td>S short bis</td>
<td>A1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T long bis</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>T short bis</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>M long bis</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>M short bis</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>R long bis</td>
<td>A4</td>
<td>A3</td>
<td></td>
</tr>
<tr>
<td>R short bis</td>
<td>A4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A long bis</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>A short bis</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>A1</td>
<td>A2</td>
<td>A3</td>
<td>A4</td>
</tr>
<tr>
<td>N long back (4Y)</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>N long front (4Y)</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>N long front (4Y)</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>S long back (4Y)</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>S long front (4Y)</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>T long back (4Y)</td>
<td>A1</td>
<td>A2</td>
<td>A3</td>
</tr>
<tr>
<td>Execution List</td>
<td>GENESIS - Operator Manual</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T long front (4Y)</td>
<td>A3</td>
<td>A4</td>
<td>T/1</td>
</tr>
<tr>
<td>M long back (4Y)</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>M long front (4Y)</td>
<td>A4</td>
<td>A3</td>
<td>A2</td>
</tr>
<tr>
<td>R long back (4Y)</td>
<td>A4</td>
<td>A3</td>
<td></td>
</tr>
<tr>
<td>R long front (4Y)</td>
<td>A4</td>
<td>A3</td>
<td></td>
</tr>
<tr>
<td>A long back (4Y)</td>
<td></td>
<td>A2</td>
<td>A1</td>
</tr>
<tr>
<td>A long front (4Y)</td>
<td></td>
<td>A2</td>
<td>A1</td>
</tr>
</tbody>
</table>

Fields marked with “bis” are fields with double front on machines with 2 fields or 4 fields in X. Fields marked with “4Y” are for machines with 4 fields in Y. Number 1 always indicates that field is of front type.
4. SYNOPTIC TABLE

4.1 Use of Synoptic Table

During execution a Synoptic Table may be opened, giving access to a serie of graphic windows displaying, on a background of the machine or of its subsystems (Groups and Subgroups), the state of its main devices, as axes co-ordinates, errors and messages. Synoptic Table also allows interaction (when not in execution) with machine devices displayed in its pages, thus providing manual and diagnostic operation.

Input devices are displayed with a LED icon, showing the ON and OFF state of the corresponding device.

4.1.1 Displaying Synoptic Table

Main Synoptic Table can be displayed as follows:

- Open Main Synoptic

  F10
  
  - Chose item Main Synoptic in View menu.

The main Synoptic window is displayed.

4.1.2 Open a new Synoptic Table

A Synoptic Table stored in the archive can be displayed as follows:

- Open Synoptic

  - Chose item Open, sub-item Synoptic in File menu.

The main window of the selected Synoptic is displayed.
4.1.3 How to come back to previous Synoptic

While operator can pass from a “hot area” to another by means of mouse, return to previous Synoptic is allowed by menu, as follows:

<table>
<thead>
<tr>
<th>Return to previous Synoptic</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item Previous Synoptic in View menu.</td>
</tr>
</tbody>
</table>

Previous image is displayed.

4.1.4 How to come back to Main Synoptic

The following command allows coming back directly to main Synoptic:

<table>
<thead>
<tr>
<th>Return to main Synoptic</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose item Main Synoptic in View menu.</td>
</tr>
</tbody>
</table>

The main Synoptic window is displayed.

4.2 How to operate on the Synoptic Table

Operator can select one of the different pages composing synoptic by double clicking mouse on an area of the machine, bordered by a hatched rectangle, also called “hot areas”.

Point on a “hot area”, a device or an axis moving mouse through the image on the graphic object desired. While moving mouse, the name of the currently pointed device appears in the Status Bar.

Mouse cursor assumes different shapes according to the object pointed, this way suggesting the action available:
4.2.1 How to act on Devices

Actions on devices are carried out by pointing with mouse on the device desired, and completing the action as follows, according to the different devices.

<table>
<thead>
<tr>
<th>Display</th>
<th>Action</th>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device icon</td>
<td>point and click</td>
<td>Digital Output</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Flag switch</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Flag bit</td>
</tr>
<tr>
<td>Box for Value editing</td>
<td>point and click</td>
<td>Analogue Input</td>
</tr>
<tr>
<td></td>
<td>set value</td>
<td>Output Port</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Flag Port</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Axis quote</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Timer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Counter</td>
</tr>
<tr>
<td>Box for value selection</td>
<td>point and click</td>
<td>Output Nibble</td>
</tr>
</tbody>
</table>

4.2.2 Moving Axes in Manual

For commanding an axis, just double click with mouse on the field displaying coordinates of the axis desired. The window displayed hereafter will open.
Fig. 4.1: Window of manual axis displacement.

The window is composed by two areas:

**Top Area**
- Three boxes displaying *Absolute Co-ordinates [mm]*, *Actual Speed [mt/min]* and *Loop error*.
- Axis *Status* during movement (ex. Acceleration).
- Two push-buttons showing axis *Status* (Free = open loop, for instance because of a system error, Normal = closed loop, i.e. in normal position control). These push buttons also allow selecting status.

**Displacement Area**
- Two boxes to set the *Negative* and *Positive Co-ordinates*, executed in *Absolute* mode.
- The editable numerical box Speed, where the desired speed for the manual movement can be set.
- One box for the *Pitch* value executed in *Step* mode.
- Three buttons for selecting displacement mode: *Jog*, to *Absolute* quote or *Step*. In the last two cases displacement may be set by means of a selection box.
- Two push-buttons for the movement in *Negative* or *Positive* Direction.
- A push-button for Stop the axis in any moment, during the movements *Absolute* and *Step*. 
5. DIAGNOSTIC

5.1 Foreword

During machine operation, a Diagnostic window may be opened, allowing Operator to check machine functionality, monitoring logic status of digital I/O signals, values of analog signals, contents of timers and counters, and axes displacements. Furthermore, by means of keyboard all command devices may be modified.

It’s possible in real time:
- to display ON/OFF status of all digital inputs;
- to activate (ON) and deactivate (OFF) all digital outputs;
- to display current values of analog inputs (within the interval +/-10V);
- to set a value on any analog output (within the interval +/-10V);
- to displace an axis manually (JOG or STEP), selecting its speed, step value or absolute final co-ordinate, displaying real position, speed and loop error; this feature allows correct regulation of the axis dynamic behaviour.

Every device is represented both with a graphic and text description, as will be explained later.

NOTE: only devices related to the current access level are displayed.

5.2 Diagnostic window

Genesis allows opening many diagnostic windows on the same module. Once the main diagnostic window has been opened, other subsidiary windows may be opened, thus allowing visibility on many devices at the same time.

5.2.1 Opening Diagnostic window

The Diagnostic window may be opened as follows:

<table>
<thead>
<tr>
<th>F9</th>
<th>Open Diagnostic window</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Chose Open Diagnostic in File menu.</td>
</tr>
</tbody>
</table>

The Diagnostic window appears containing the list of Groups, with their descriptions.
5.2.2 Opening subsidiary Diagnostic windows

Subsidiary Diagnostic windows may be opened as follows:

<table>
<thead>
<tr>
<th>Open a subsidiary Diagnostic windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Chose New window in Window menu.</td>
</tr>
</tbody>
</table>

A new window appears with the Module Devices. By means of commands available in menu “Window”, all windows may be arranged as desired, and displayed all together.

5.2.3 Window Composition

Making reference to the structure “Groups / Subgroups” described in Chapter "System Composition", the operator has access to devices, that are displayed in a tree structure. At the first level of this structure we find:

Followed by Name and Comment of Machine or Group

The structure may be opened by clicking on button that transforms itself in thus allowing to close the structure when pressed again. The tree structure may also be opened by pressing keys: +, -, Enter and Space Bar.

When a Group is opened, the tree will display:

• The Group "Device List", represented by symbol ;

• Subgroups composing the Group, if existing..

When one of the Subgroups is opened, the devices composing it are displayed.

Keys Home and End allow selecting the first or last item listed, while keys PgUp and PgDn scroll the pages displayed.

A device may be selected by means of arrow keys, or pointing with mouse and clicking left button.
5.3 **Device Representation**

The following information are displayed for each device:
- Graphic Symbol;
- Current status or value;
- Name;
- Comment.

The device representation is shown hereafter, with their meaning and the information displayed in real time.

Status of digital inputs and outputs is graphically displayed by a LED assuming different colors according to the input being active or inactive.

In case of ports, that means more lines represented in the same time (4 or 8), an array of LEDs appears, where the rightmost one represents the first line of the port, the leftmost the last line.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Type of device</th>
<th>Display in real time</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Digital Input" /></td>
<td>Digital Input</td>
<td>status: Active = GREEN, Inactive = GREY</td>
</tr>
<tr>
<td><img src="image" alt="Digital Output" /></td>
<td>Digital Output</td>
<td>status: Active = RED, Inactive = GREY</td>
</tr>
<tr>
<td><img src="image" alt="Analog Input" /></td>
<td>Analog Input</td>
<td>Current value</td>
</tr>
<tr>
<td><img src="image" alt="Analog Output" /></td>
<td>Analog Output</td>
<td>Current numerical value in Volt</td>
</tr>
<tr>
<td><img src="image" alt="Input Port" /> (8 digital lines)</td>
<td>Input Port (8 digital lines)</td>
<td>status of each line (like Digital Input)</td>
</tr>
<tr>
<td><img src="image" alt="Output Port" /> (8 digital lines)</td>
<td>Output Port (8 digital lines)</td>
<td>status of each line (like Digital Output)</td>
</tr>
<tr>
<td><img src="image" alt="Input Nibble" /> (4 digital lines)</td>
<td>Input Nibble (4 digital lines)</td>
<td>status of each line (like Digital Input)</td>
</tr>
<tr>
<td><img src="image" alt="Output Nibble" /> (4 digital lines)</td>
<td>Output Nibble (4 digital lines)</td>
<td>status of each line (like Digital Output)</td>
</tr>
<tr>
<td><img src="image" alt="DC Axis" /></td>
<td>DC Axis</td>
<td>Absolute current position</td>
</tr>
<tr>
<td><img src="image" alt="Timer" /></td>
<td>Timer</td>
<td>Current value in seconds</td>
</tr>
</tbody>
</table>
5.4 Interacting with Devices

For diagnostic purpose, a device may be operated, in order to read its status or modify its value.

This cannot be done on some devices, as the inputs or devices protected by machine builder; in this case a warning message informs the operator in case he tries to modify the device status.

Once selected a device, **double click** with mouse, or press key **Enter**, or **Space Bar**, or key +, to access the dialog window that allows editing device status or value.

In case of **Digital Output** or **Flag bit**, no window appears, but device status is toggled immediately. Output functionality is tested by checking colour modification of the corresponding LED.

In case of **Output Port** or **Output Nibble**, point with mouse on the selected output and **double click** to toggle its status.

The same is valid for **Flag switch** and **Flag Port**.

For **Analog Outputs**, **Timers** and **Counters** a dialog window appears that allows setting the new value that the device will immediately assume.

Interaction with an **Axis** is described in Chapter "Axes Displacement in Manual", within "Synoptic Table".